Playroom client 3.0 beta

348 messaggi, 12 pagine: 1 …  7 89  10 11 12 ↖ Torna alla lista degli argomenti

241. Nikola,

Hello,
thanks Aminiel, the scores are working properly now.

That being said, do you know if the game locking bug is now definitely fixed, or it's still unknown?
If it is fixed, then perhaps the reordering is worth it and we will get used to it.
I do have to say for now though that it is sometimes really confusing, and even though I have been playing Uno for years with this new order of information I sometimes have no idea how or why something happened.
I will give short 2 examples with bots:

Example 1:
Noob's spirit says: uno!
Noob's spirit plays a green 8.
It's your turn.
You play a green 4.
It's Noob's spirit's turn.
You play a green 3.
Noob's spirit plays a green 5.
Nikola gets 75 points.

Here, it is a little weird that the bot first says Uno, then plays his second card, "Green 8". Even I was able to do this once myself, but now I can't reproduce this, so it is not just bots who do this, though I currently don't know how or why that happens with humans. Normally, of course, Uno should be said after playing the card, not before.

Now, the second example:
You play a red draw two.
Nikola says: uno!
Noob's spirit draws 2 cards.
It's your turn.
Noob's spirit plays a green draw two.
This one is a little strange. I don't understand why should it be my turn if the bot clearly has a playable draw 2, but even more so, if it is my turn, how can the bot play a green draw 2? Unless of course this is considered an interception, but it was not reported as one.

I guess this all isn't as bad with humans, and of course, if there is no other solution to fix the major bug, there is no choice but to get used to it, as I said it just looks a little strange sometimes. Also with the bluff rule, it first tells you whether you draw 6 cards or your opponent and then that the other person was or wasn't bluffing. But all of this is not consistent. Once it is one order, and another time it is a different one. Sometimes it first reports the bluff result and then the cards drawn, and then another time it will do the opposite, report the cards drawn and then the bluff result.

Thanks in any case for your efforts trying to fix this annoying game locking bug, and I hope it is gone now.

242. Aminiel,

Hello,

That being said, do you know if the game locking bug is now definitely fixed, or it's still unknown?

It's still unknown. Let's see if it occurrs again in the next few days with these changes.

For your first case, I don't find it really problematic. In real life, some players say uno at the same time or slightly before playing their card, and it's generally acceptable. You have the alarm sound anyway.

For your second case, if it doesn't say interception explicitly, then it isn't an interception.

That being said, maybe I can still improve a little the grouping of messages.

243. breaker,

Hi. I get very critical errors. My game, main menu. Shortly, all of game's object has no sound. Please help. Here is the "debug.log". appDir = C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta
Found datafile in C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\sounds.dat
Couldn't open datafile C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\sounds.dat
Initializing SSL configuration...
Couldn't find SSSL trust store file truststore.pem
Loading user config...
No config.ini found, fallback to default configuration
AppsUseLightTheme = 1
Dark mode = false
Initializing locale...
No locale set in the configuration, retrieving system default
Locale configured to 'tr_TR'
Loading translations...
Loading translation module: client...
Translation module client for locale en found in C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\lang\client_en.tm
Opening datafile C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\lang\client_en.tm...
Couldn't load translation module C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\lang\client_en.tm
Initializing UniversalSpeech...
NVDA detected, but unable to get its version
UniversalSpeech initialized: engineID=2, engine=NVDA, subengine=0, language=0, voice=0, volume=0, pitch=0, rate=0, inflexion=0
Initializing BASS audio...
Initializing BASS default device using WASAPI
Info for device 1: latency=25, freq=96000, speakers=2, dsVersion=9, minBuffer=10, hasEAX=false, freq range = 0-0, hwMem=0/0, hwFreeSamples=0, hwFree3D=0, initFlags=0X104, capFlags=0
Default stream audio buffer set to 43ms
BASS Error 23 (Invalid device specified)
Found 6 available devices; default=1
Device 0=No sound
Device 1=Default
Device 2=Hoparlör (Realtek High Definition Audio)
Device 3=4 - DDC Display (AMD High Definition Audio Device)
Device 4=Hoparlör (USB PnP Sound Device)
Device 5=Realtek Digital Output (Realtek High Definition Audio)
Initializing device 1 (default) for sound.device
Device 1 (default) for sound.device is already initialized
Initializing device 1 (default) for notifications.device
Device 1 (default) for notifications.device is already initialized
Initializing device 1 (default) for streams.device
Device 1 (default) for streams.device is already initialized
Loading BASS plugin bass_aac...
Loading BASS plugin bassflac...
Loading BASS plugin bassopus...
Loading BASS plugin basswma...
Loading BASS plugin basswv...
Loading BASS plugin bassmodplug...
Loading BASS plugin basshls...
BASS audio initialized and configured
Initializing main window GUI...
Loading image resources images.dat
Found image resources file in C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\images.dat
Loaded 86 images resources (9668 bytes)
Window size = 1092, 614
log area pos = 0, 0, 538, 548
menu list pos = 542, 0, 534, 548
Initialized main window GUI
Loading sample welcome...
Joystick input supported
Tasbar tray icon: available=true, activated=false
Starting worker thread
Loading sample connecting...
Connecting to game.qcsalon.net:1443 (secure=true)...
Set TCP socket options: nodelay=true, keepalive=true, dontlinger=true
Connection established in 487ms
IPAdapterInfo: type=6, name={AF5774F1-0E25-4C20-AA3C-248A5D20E8CC}, description=Realtek PCIe FE Family Controller
IPAdapterInfo: type=6, name={D832994F-514F-4FAD-AD40-D3981DC3BCEE}, description=Remote NDIS based Internet Sharing Device #3
Logging-in: username=breaker, language=en
Done reading headers
Login refused
Saving configuration to C:\Users\bilal\OneDrive\Masaüstü\Yazar Panda downloads\qcgc-v3-beta\config.ini
Websocket write failed:
Stopping worker thread
Closing audio devices...
Audio devices closed

244. Nikola,

Hello,
Aminiel, is this a WX bug or you have a way to fix it?
When you press shift f10 on the history edit box, you get an incorrect context menu with options to copy, paste, select all and so on.
However, when pressing the applications key, the correct menu opens and you get the option to clear the history.

Some keyboards don't have an applications key, so if you could fix this so the correct menu opens with shift f10, that would be great.

Alternatively, if it isn't possible, you could add another way to clear the history, via a shortcut or the f9 menu for example.

Thanks.

245. Aminiel,

Hello,

Beta version has been updated !

Breaker and Nikola, this version should solve the problems you mentionned just above. CAn you confirm that it works now ?

246. Nikola,

Hello,
for my part I confirm that shift f10 now opens the correct menu, thanks for a very quick fix.

Ultima edizione da Nikola, 01.08.2021 14:08:29

247. Fawaz,

Hi,
For whatever reason, sending permanent message no longer working..
not only from the beta client, but also from the old client.
thanks.

Ultima edizione da Fawaz, 30.07.2021 16:55:37

248. Dante_Storch,

hello, if the user who wrote before me is right, there are problems while embeding permanent messages since the last update, how could it be fixed? Thank you.

249. Nikola,

Hi,
yes, it seems that it's now impossible to send permanent messages from the client.

As a temporary workaround until this is fixed, you can send permanent messages from the website.
Go to your inbox and choose open on the web, that should take you directly to the permanent messages page on the website.
Log in if necessary, and near the bottom of the page, the last heading you will find is to send a new permanent message.
Just fill in the same data as on the client, and this works fine as far as I tested.

250. Dante_Storch,

you mean if you can from the citio wev?
jenial! i thought it didn't work in all instances.

251. Lieta,

Hello, since I started using the last update I receive this message when opening the qcg.exe file. Message diálogo 16:29:55: Error: can't open file 'debug.txt' (error 5: Acceso denegado.)
When I press accept I can connect normally, but itis the first time I read something like this and I wanted to report it. Thank you!

252. Dante_Storch,

Hey,
I've been asking myself a question.:
if there is client 3.0, will there also be citio wev 3.0? or just client, is that: I find it worrying that the wev is not updated.

Ultima edizione da Dante_Storch, 31.07.2021 16:56:38

253. Lieta,

Hi again, I have opened the qcg.exe file as an administrator and the message isn't showed now, don't understand why because I'm bad at these issues :D but there you have my situation

254. Nikola,

Hello,
after using this version for a day, I have a somewhat strange situation.
I have disabled auto login to test something, and everything worked great.
However, now I can't enable auto login again.
When I enable the option, the checkbox is checked, but after I restart the client the client asks me to confirm my username and password and doesn't auto log in.
If I go to options again, I can see that the auto login option has been disabled.
I can do the same again, enable auto login, but when I restart it gets disabled again.
It seems that I now have 2 files config.ini.
The one is located in the client directory, and another one in my user folder, appdata/roaming/QCGCWX30.
In the config file in Appdata, the general.autoLogin is set to false, but in the client directory's config.ini file, general.autoLogin is set to true.

I can modify this ini in appdata and set it to true there as well, and the auto login is now enabled correctly, but I again can't disable it from the options menu if I want to do so.

I am not sure why there are now 2 configuration files, should I delete the one in the client directory and will the client now correctly use only the one in appdata?

There might still be a bug, as the client should modify the correct configuration file when changing options, or I have just encountered something very strange.
Thanks.

255. Aminiel,

Hello,

Nikola, that's a very, very strange situation. The simplest to sort that out is probably to delete both files and then see where it is recreated. Logically it should recreate the config file only at one place and then stick to it. Does it happen again after that ?

Does your windows user name contains spaces or accented characters ? Does the directory where you extracted the playroom do ?
Version 2.99.44 should have fixed problems with spaces and accented characters, but I may still have missed something somewhere.

256. Nikola,

Hello,
yes, you were right, deleting the config in both places now solves the problem.
The client now correctly saves settings in it's own directory.

Regarding accented characters, no, my Windows username and the client directory both contain only standard simbols.
However, on a Serbian mailing list, there is a report that the client doesn't work properly if it is run from a cyrillic directory.
In fact, it connects and launches normally, but the automatic screen reader speech doesn't work.
Maybe an universal speech bug?
I have tried pasting the entire debug file in my previous forum message, but for some reason, that made the message completely empty and not display correctly.

I assume the problematic part is this:
Initializing UniversalSpeech...
UniversalSpeech initialized: engineID=-1, engine=None, subengine=0, language=0, voice=0, volume=0, pitch=0, rate=0, inflexion=0

If needed, I can send the entire debug file some other way.

I will try to also paste the cyrillic directory, but if that makes the message again empty I will edit the post to remove it, though that really should not cause problems on the forum because we normally send cyrillic texts over permanent messages and it works fine.
The full path from which the client was launched is D:\портабилни програми\QCGC V3

Ultima edizione da Nikola, 01.08.2021 14:20:45

257. Aminiel,

Hello,

UniversalSpeech initialized: engineID=-1, engine=None, subengine=0, language=0, voice=0, volume=0, pitch=0, rate=0, inflexion=0

It seems that no screen reader has been identified. Do you know which one that person is normally using ? Jaws, NVDA, windows narrator, another one ?

Maybe it's effectively an UniversalSpeech bug. Something to try is obviously to extract the playroom in a directory having only ASCII characters a-z A-Z 0-9 and no spaces. If it works in this situation, then, yes, probably there is something I need to fix.

258. Nikola,

Hello,
the screen reader being used is NVDA, and yes, when the Playroomm is copied into a directory with only latin characters, it is correctly detected and the speech works normally.

For reference, I have uploaded the complete debug file of the incorrect detection.
You can read it at https://www.dropbox.com/s/b4c7jpm2pp3qs2k/debug.txt?dl=1

259. Aminiel,

Beta has been updated !

With this beta, we are approaching the final phase. From now on, portable zip is replaced by an installer.
The goal will be to test this installer, and the updates, which will now become automatic.

The new download link is as follows:
http://qcsalon.net/autodl/qcgc-beta-setup.exe

260. the-chaos,

hey, thanks for the installer! I cannot save history anywhere after installing the beta. it shows the directory I selected, but the logs aren't saved. am I doing anything wrong?

261. Aminiel,

Hello,

Installable beta wasn't supposed to replace version 2.2.8. Beta versions are especially done to spott that kind of bug.

If that happened to you and it isn't what you wanted, you can do the following:

Parameters being separated in two different directories (QCGC and QCGCWX30), and install ID key being different, they are supposed to be both installed without any problem.

Eventually when 3.0 will be official, it will effectively replace 2.2.8, but it isn't the moment yet.

262. the-chaos,

I didn't have 2.2.8 installed, but the problem fixed after I restarted the client, thanks.

263. slann-tonic,

Now I ask: When official 3.0 version is released, will it replace the beta? or I'll have to reinstall.

264. Nikola,

Hello Aminiel,
the problem with V3 replacing V2 is related to the shortcut name.
For example, try installing first the V2 into a different folder, let's say C:\Programs\QCGC V2
Now, install V3 into it's default directory.
The problem here is that they both create desktop and start menu shortcuts named "QuentinC's Gameroom"
Thus, when V3 is installed over V2, it will effectively replace it's shortcuts, no matter which directory, and since people usually start installed apps through their shortcuts, the logical conclusion is that V2 was replaced by V3.
Of course, if you manually go to your V2 directory, in my example that was C:\programs\QCGC V2, you can easily re create the shortcut to qcgc.exe and call it something different.
In my opinion, you should do the following:

  1. In the V3 installer, specify a different shortcut name, for example QuentinC's Gameroom beta or QuentinC's Gameroom V3.
  2. Also in it's installer, specify a different default directory for installation so people don't have to reinstall V2 and change it's directory.
  3. Something like "C:\Program Files (x86)\QuentinCGameroom beta" should work better.

Thanks for the update, and very glad to see the progress.
I wonder how close we are to the new surprise...

265. sukil,

I have uninstalled everything, and installed it, changing the installation folder and the shortcut folder for this reason.

266. Nikola,

Hello,
nothing was posted, so I am not sure if we were even supposed to receive an update, however I was offered to download a new update, 2.99.47.
First, something strange happened. When I logged in, the update dialog appeared briefly for a few seconds, and then the Playroom reconnected me and shown this same dialog again. This might have just been a connection issue.

However, after the update was successfully installed, for some reason, I lost my configuration and all the settings were reset to their defaults.

I am really not sure how or why that happened.
I will give a link to the debug. This debug contains the info from before the update as well as the first log in after the update.
It for some reason can't find the config.ini file, so it would seem as if it was for some reason deleted during the update.

The debug file can be found at https://www.dropbox.com/s/d95jk70tlu422ug/debug.txt?dl=1

267. Undead,

Greetings, would it be possible to consider implementing the one that can be sent private messages in group?
example.
@ 1, @ 2, @ 3 and etc. all separate by a semicolon or so or enclosed in quotation marks and that the message reaches all those mentioned

268. Aminiel,

Hello,

I put a 2.99.48 online. Can you tell if configuration is again deleted, or if it is kept this time ?
Thank you.

269. Nikola,

Hello,
thanks, I updated from 2.99.47 to 2.99.48 and this time, the configuration was not deleted.

270. semitdoog,

Hi. When you are spectating a game, when the game ends you hear the sound meant for the player who lost.
Is it possible to add a different sound for such a situation where you are neither the winner nor the loser?

348 messaggi, 12 pagine: 1 …  7 89  10 11 12 ↖ Torna alla lista degli argomenti

Rispondere all'argomento

Devi aver loggato per postare.