Can connection issues be fixed?

12 messages, 1 pages: 1  ↖ Go back to topic list

1. alphaxploder ,

I hope this is the right topic. I'm sure many people know what I am talking about here. When someone sends you a message, or a message on the table sometimes your connection breaks and you don't see it, and when it happens over and over and over and you keep getting disconnected and reconnected it gets a little annoying. I'd really appreciate if this bug could be fixed

2. augma,

its a bug

3. Nikola,

This is related to a past issue Aminiel knows about, and it is that if you are inactive for several hours your connection will drop. The only problem is that now instead of several hours, it is much worse for me, more like about 15 to 20 minutes. If you stay inactive during this time, one of three things can happen:

  1. You lose connection, and if you press w for example you will get no output. However, this is the best case, since this is only a temporary timeout and if you wait a few minutes, your connection will be back and you will get all the messages you missed in one single large mix of sounds, which is quite amusing.
  2. Your connection drops in a similar way to the option 1, except if you wait a few minutes, you get all the messages and then your client just closes. This one actually started happening recently, perhaps just after the last server update.
  3. Finally, the worst case is that you lose connection, and pressing w will play the reconnect sound and throw you back to the main room losing all the messages you have missed.
  4. Honestly have no idea why this is happening, because of this issue alone I was considering making a script to focus the Playroom window and press w each 5 minutes just to not be inactive to avoid this issue. However, this is obviously not a good solution since it makes the absent status pointless. I hope the solution to this will be found at some point, as it's probably one of the most annoying things. Never tested to see if the web client behaves the same.

4. marina7,

I guess he means also some other strange bug, in which some messages of a player can cause another specific player to get disconnected, just because of the message.
So to explain myself more, let's say the bug happens with me and Nikola, so in some random message whether it's a pm or a public message at the same table, the following happens:
Nikola has been suddenly disconnected
Marina7 says: hi
nikola has just reconnected.
And, for Nikola, he gets that disconnecting and reconnecting sound and he loses my message.
However, I never reported this bug before because it's very random. I couldn't figure out the reason for it to be produced, and also, as I mentioned it's very random, meaning it does not happen with every single message, so this is also another thing that makes it hard to detect I guess.
When the player who causes the disconnection leaves playroom and comes back most of the times it gets fixed also.

Latest edition by marina7, Sep 22 2019 17:28:10

5. Lemonade,

I have never actually seen this bug in action before... Interesting.

6. Nikola,

Yes, that second bug with connections is also present. In my experience it happens when somebody is online for a longer period of time, but same as Marina I always found it to be quite random.

7. sound2,

I get the first 2 issues nikola mentioned. I thought it had something to do with my internet connection which has been quite bad lately. I didn't realise being inactive could cause the playroom to disconnect.

8. alphaxploder ,

Yes I was talking about the message bug.

9. Aminiel,

Hello,

This kind of connection bugs are extremely hard to catch and fix. Unless someone finds a specific reproducible pattern, every trial is mostlyvoid.

This let me think to Something still unsolved: the 6-8 hours bug is still here. If you have been inactive for that long and suddenly get a message, you may be randomly disconnected and right reconnected.

However, as far as I knew that bug til now, the disconnection was very short (at most a few seconds), and you must be totally inactive for that time, meaning Don't send anything to the client: no message, no key press…
That's the first time I heard about this happening after a much shorter time than a few hours, and cuts lasting more than 3-5 seconds.

10. StormProductions,

For me it doesn't happen at all. Probabbly it's a bug that's happening for some users only.

11. helleon,

At least this issue might help to regulate the users, who still exist here, that create tables for hours on end and disappear

12. Nikola,

I wish, but sadly users actually don't intentionally do that, that's also some bug. I saw tables like that even when said user is not online lasting for days. Helpers are generally pretty good at shutting those down though, so thanks goes to them.

12 messages, 1 pages: 1  ↖ Go back to topic list

Answer to topic

You must be connected in order to be allowed to post